Livewire Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Both a PSA and an inquiry. Yesterday I was unable to use an EVgo DC fast charger (Level 3 SAE combo) and after a call with their customer service team they informed me that Harley hadn't reached out to them for testing and they don't support LiveWire charging. The process read the bike and then shut off. Suffice it to say, the onscreen instructions include "insure the vehicle is in Park and turned off." Has anyone got DC fast EVgo to work with their LiveWire after the latest HD software updates? They are listed on HD Connect and ChargePoint's apps as part of our Level 3 network but useless, as far as, I can tell. At least the ChargePoint app tells you who the vendor (EVgo) is before you arrive. HD Connect doesn't tell you until you have driven out of your way for something that wont work.
321
 

·
Registered
Joined
·
3 Posts
Anyone else confirm this? Planning on buying a Livewire in a week or two and this would be a pretty big deal here in Colorado, they have most of the DCFS in the state.
 

·
Registered
Joined
·
6 Posts
I've visited three EVGo level 3 DC fast charging stations so far. Aside from the total price gouging ($0.23/min), I've had two out of three seamless, successful charges. The third one was similar to your experience @Michelle. It shut off, saying there was an internal error. But I reconnected it and started it again and it completed no problem.

Ideally I'd be using Electrify America because of the testing that's taken place and the two free years of charging. Unfortunately I live in San Diego, where there are almost ZERO Electrify America stations. The "coming soon" grayed out map icons are almost comical. It's the largest "coming soon" charging network in there country for sure ;)
 

·
Registered
Joined
·
250 Posts
I've visited three EVGo level 3 DC fast charging stations so far. Aside from the total price gouging ($0.23/min), I've had two out of three seamless, successful charges. The third one was similar to your experience @Michelle. It shut off, saying there was an internal error. But I reconnected it and started it again and it completed no problem.

Ideally I'd be using Electrify America because of the testing that's taken place and the two free years of charging. Unfortunately I live in San Diego, where there are almost ZERO Electrify America stations. The "coming soon" grayed out map icons are almost comical. It's the largest "coming soon" charging network in there country for sure ;)
Is your Harley dealer near you? Their chargers are part of the ChargePoint network and you can use any ChargePoint station anywhere for the 2 years free charging. The EA network is for 500kWh of free charging in 2 years.
 
1 - 6 of 6 Posts
Top