Livewire Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter · #1 ·
Rode Portland your the coast and back. 235 miles total. 3 charging stops. Tillamook public utility hat two free high speed charge point units. Only had to wait about ten minutes. Last stop had 17 miles left but couldn't get it to work. Had to ride 15 now miles. 2 percent left. Watch out for these units. Livewire knows about it. This one was electrify America. Also electric avenue which is the local portland utilities chargers uses them .
Sky Motor vehicle Plant Asphalt Tree
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #3 ·
Also stringing together charger stations to go distance is kinda fun. Sort of a fun adventure. But I notice it causes me to ride slower then I might if that risk wasn't there. Still some fun acceleration but average way lower then I imagine a smaller gas bike would.
 

·
Registered
2020 H-D LiveWire
Joined
·
55 Posts
Have had issues with Electrify America and Charge Point units in our Audi e-tron (have only used the Charge Point units at H-D dealers so far on my ELW, with no issues); in every instance a call to the 800 support number on the charger unit has rectified the problem within minutes -- usually with them forcing a reboot of the charger.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #5 ·
Have had issues with Electrify America and Charge Point units in our Audi e-tron (have only used the Charge Point units at H-D dealers so far on my ELW, with no issues); in every instance a call to the 800 support number on the charger unit has rectified the problem within minutes -- usually with them forcing a reboot of the charger.
Didn't work at Paradise in Tigard Oregon but there is a rumor that some of them require an upgrade to work since the cell phone changes last year?
 
1 - 5 of 5 Posts
Top