Livewire Forums banner
61 - 65 of 65 Posts

·
Registered
Joined
·
6 Posts
I too am having problems connecting my iphone 12 pro to my livewire. I have been able to connect my phone to the new livewire in the the dealership multiple times. I dont know what the difference as they both have the same software version. Currently I am waiting to hear from the motor co as to if they will swap out the ICM.
 

·
Registered
Joined
·
19 Posts
I had to do a complete wipe of the phone to get it to work and after iPhone updates it shows as 00:16:A4:4C:C9:BB It’s definitely on Harley’s side and they refuse to use all our extra $7Ks to help us.
623
Font Screenshot Number Rectangle Parallel
 

·
Registered
Joined
·
1 Posts
Hi Everyone,

I've been following along with this post and seen there really hadn't been any real resolutions so I decided to get with H-D and Apple.

I tested a couple older iPhones and current/old Androids. Those all connected just fine and H-D basically said since those all connected it's not the fault with the bike.

I then got in contact with Apple Support. Went all the way up the chain to where I was dealing with engineers. Went through a multitude of tests and diagnostics and they weren't coming up with anything.

Finally they suggested the "last ditch" test.

1. Screenshot all of your apps
2. Back up everything to my iCloud.
3. Erase All Content and Settings
4. Reboot phone
5. Select option of "Don't Transfer Apps & Data"
6. Log in with your Apple ID
7. Finish setup

After all of that, I turned on the bike and my phone connected right away to the bike. Now just have to go back through and re-download my apps.

It's kind of a pain, but hate not being able to control my music on the bike.

Hope this helps!!
Ryan
 

·
Registered
2020 Harley-Davidson LiveWire, Vivid Black
Joined
·
1 Posts
I’ve only been able to pair with my iPhone 12 Pro Max if I use the LightBlue app (a BLE debugging tool from Punch Through) to do so - instructions are on my blog at https://allen.blog/2021/10/02/debugging-harley-livewire-bluetooth-and-iphone-issues-part-2/

Even with pairing resolved, I still find that my phone only automatically reconnects about every other time and sometimes I have to power cycle the bike twice to get it to reconnect. Still debugging that.
 

·
Registered
Joined
·
6 Posts
Hi all, I have just had this problem.. used to have an iphone 12 pro which connected to the bike okay then just swapped to an iphone 13 pro and it wouldn't even find the bike...!

i downloaded the Lightblue app (for finding bluetooth devices and diagnosing them) found it straight away and connected no problem.. now all connected and working

Cheers
 
61 - 65 of 65 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top